Customer Service 877.625.7872 | Technical Support 888.565.3200
Nex-Tech Help Desk
Mon. - Fri. 7AM - 11PM
Sat. - Sun. 8AM - 8PM
or call 888.565.3200

Setting File Associations

Setting File Associations



The Windows operating system recognizes file types and associates them with programs based on their file extension. For example, Windows might recognize filename.htm as being associated with Internet Explorer or Firefox. When a user opens filename.htm, Windows will first open Internet Explorer which will then take over opening the file. When Windows is first installed, certain file type associations are automatically assigned, i.e. the default handler for .TXT files is the Notepad program executable, Notepad.exe


To display file name extensions in Windows

Depending on your settings, the file name extensions of your files may not be visible. To display the file name extensions of your files if they are not visible, follow these steps:

  1. Open My Computer or Windows Explorer.
  2. On the Tools menu, click Folder Options.
  3. Click the View tab.
  4. In the Advanced settings box, click to clear the Hide extensions for known file types check box.
  5. Click OK.


To change which program starts when you double-click a file in Windows

NOTES:

  • You will most likely have to go through this feature if the customer is trying to open a .pdf and it does not point directly to Adobe Reader, or they have a word attachment that does not open with Microsoft Word etc.

  • You cannot use this method for a file that does not have a file name extension, or for a file that has an .exe, .com, or .bat extension.
  • If you change the program that Windows uses to open a certain kind of file, and that program was not designed for the type of data in that file, the files may not appear correctly in the program. To be safe, note the name of the program that Windows previously used to open the file type so that you can reverse your settings if it is necessary.

To change which program starts when you double-click a file, follow these steps:

  1. Open Windows Explorer by right-clicking the Start button, and then click Explore.
  2. Click a folder that contains a file of the type that you want Windows to open in a program that you select.
  3. Right-click the file and, depending on the programs installed on your computer, complete one of the following steps:

    • Click Open With to choose the program that you want.
    • Point to Open With, and then click Choose Program to choose the program that you want.


  1. The Open With dialog box is displayed. Use one of the following methods to select the program that you want to use for this file type:

    • In the Programs list, click the program that you want to use.
    • Click Browse, locate and select the program that you want to use, and then click Open.
    • Click Look for the appropriate program on the Web to browse the Internet for the program that you want to use. If you are still unsure, Google the file extension. You should then be able to find a program that is associated with that file type.


  1. Click to select the Always use the selected program to open this kind of file check box if it is not selected.
  2. Click OK.

Back to Top of Page


To change which program starts when you double-click a file in Mac OSX


  • Mac OSX makes it easy to change file associations, which determine what programs are used to open various file types.

  • To change what program opens a specific file, you first need to open the file''s information window. This can be done by selecting the file and clicking Get Info from the File menu. Or you can simply right-click (Control-click for single button mouse users) on the file and select Get Info from the contextual menu that pops up. The information window should look something like image below:



  • Notice the section in the middle of the window that says Open with. When you click the drop-down menu, it will show you a list of programs that can open the file type you are viewing information for. If the file is a Microsoft Word document, the list of programs may look something like the screenshot below:
  • Select the program that you would like to open the file and close the information window. When you double-click the document, it will open using the program you selected.


  • You can also change what program opens all documents of a certain file type. For example, you may want all Microsoft Word documents to open in AppleWorks. To do this, first select AppleWorks 6 in the drop-down menu, as in the example above. Then, before closing the window, click the Change All... button. You will be prompted to confirm the change with an alert window:


 Back to Top of Page